FVP Manual - Program Overview

Table of Contents

Opening Files

To open any file in File Viewer Plus, simply drag and drop it onto the program window. Alternatively, you can choose File → Open... from the program menu. When opened, File Viewer Plus intelligently tries to recognize the file type and displays the file. In addition, File Viewer Plus provides whatever additional information it can about the file.

Drag and Drop

After opening your file, File Viewer Plus displays two panels: a file information panel on the left, and a native view panel on the right. The left information panel displays information about the file and is customized for different file types. The right panel shows a native file view and provides helpful tools that can be used to adjust the view and edit the file. In the program toolbar, you can switch the right panel between native, raw text, hexadecimal, and icon perspectives (more on the Text, Hex, and Icon perspectives later).

User Interface Overview

File Information Panel

Here are descriptions for the different sections shown in the left file information panel:

To hide the information panel, you can either click the left arrow in the upper right corner of the panel, click the "Info" button in the program toolbar, or uncheck View → File Information from the program menu. You can also show the panel again by toggling these options. To hide the information panel by default when opening files, choose File → Preferences... from the application menu, and check the "Hide the left information panel when opening files" option.

Lastly, you can export the information from the left file information panel to a text file by choosing File → Export File Info... from the program menu.

Native View Panel

The native view panel allows you to view and edit your files before converting or saving them. Different types of files have different tools and options for viewing and editing. To see information about how to view, edit, and save different file types, refer to the other sections of the user manual.

If File Viewer Plus shows "No native view available" in the native view, then the file is not recognized.

No Native View Available

This could be due to a few reasons. First, File Viewer Plus may not support this format (see the File Types page for supported file types). Secondly, it's possible that this file is corrupt. For example, if the file has the file extension .JPG and File Viewer Plus says no native view is available, it is likely that this is not a valid JPEG image. Lastly, the file itself may not ever be meant to be viewed. For example, system files, such as .DLL or .SYS files, are not meant to be viewed like traditional image files are.

To view more information about your file type, click the link under "More information." This will redirect you to FileInfo.com, which will provide a description of the file type.

Text, Hex, and Icon Views

The Text and Hex views are for advanced users who want to be able to see files in a raw format. The Text view displays a raw text view of the file, and the Hex, or hexadecimal, view displays the hexadecimal representation. The icon view shows the different icon image sizes used by Windows to display the file in the Windows Explorer.

Text and Hex views are useful for inspecting the contents of files. Users can locate hidden information, identify unknown files, or identify file signatures based on these views. Each of these views are searchable so that you can locate information quickly without having to scan manually through the file. File Viewer Plus can display files of virtually any size with these two views.

User Interface Skins

File Viewer Plus provides two user interface skins, one with a dark theme (the File Viewer Plus default) and one with a light theme. You can change the skin from the application menu by choosing View → Skin → Dark for the dark skin, or View → Skin → Light for the light skin.

Skin Options

Batch Conversion Interface

File Viewer Plus includes an advanced batch converter that allows you to convert hundreds or thousands of files at once. Open it by choosing Batch → Open Batch Converter... from the application menu.

Open Batch Conversion Interface

Specify your batch job parameters and then click the Convert button to start a conversion. To read more about batch conversion, please see the Batch Conversion section.

Batch Conversion Interface

← Manual index | What's new →